The Invaders – Zaccaria

Totally dead, no screen display (blank white screen).  For this I used the Fluke Z80-S2650 adapter to check out the ram and rom, and located two errors. The rom mapping was incorrect, with a large range of locations returning random values. Examining the board (since I have no schematics), all of the chip select lines meet up…

Sega System 16

Altered Beast – Colours missing, no reds, other colours looked like diminished palette (like windows in 16 colours) – used test mode to perform ram test, and one ram chip identified as faulty (I10). Replaced this and red was back, but still reduced pallette. Looking at colour circuit, and it uses resistor arrays driven by I11…

Rainbow Island

On power up – black screen, no sign of life at all. I removed the 68000 CPU and fitted a socket, so I could use the Fluke on it. This revealed that the main program ram ($10C000-$10FFFF) was totally dead. Replacing the two ram chips IC25 and IC26 solved this problem. Board now started up,…

Pacman

Screen filled with coloured lines, unstable, no sync (see above) – check clock signals from horizontal and vertical scan generators (74161’s at 2R,2S,3R,3S) – no signal feeding into pin 2 of horizontal generators. Follow trace back to 7474 at 3N, signal going in, nothing coming out – replace chip and screen display back to normal….

Neo Geo

6 Slot – Memory test on power up giving error  Address    Write Read  00008000 5555 55FF Checking with Mame, the memory chips in question were only small, so looking at the board revealed two DIL 5814’s. Chip select signals to these were toggling as expected, so I needed to identify which ram chip was which….

Mr Do!

Blank screen, Blanking line to output colour proms always enabled. Trace back to 74161 in timing circuit – output stuck, input clock all look OK – replace chip and picture appears. Blue video only – The video lines are controlled by three transistors near the edge connector, checking these revealed that 2 were not giving…

Moon Cresta

Boots up, and plays, but incorrect sprites – most noticeable little bug changes into ‘END’ at one point. Check 74ls138 at 8n, controlling graphics banking, and pins strobing. Replace chip and now uses correct sprites. Quiet missile sound and explosion sound. Both of these effects use the op-amp chip, LM324 at 7T. Replace this chip…

Missile Command

The board originally failed to get into the game, instead resetting just after drawing the ‘MISSILE COMMAND’ logo. Test mode faired a little better, managing to report RAM OK, MAP OK and ROM OK before resetting. Ram and Rom checked out OK using the Fluke. Measuring various CPU signals revealed that the interrupt seemed very…

Make Trax

Boot up with garbage, quickly clears screen and then nothing. Used Fluke with Z80 pod – read rom OK, and write ram OK, but timeout reading any Ram location. Check fluke status and ‘wait’ always set. Check pin 24 of Z80– stuck low, trace back through 7H,7C,6C1 to 6B1 pin 2 – always low, although…

Lady Bug

Board ID 8016 : Falcon version ? Static graphics on screen, dead – pin 24 low on Z80, /WAIT signal. Trace signal on board to 74LS74 at E7. Signal incorrect for inputs. Replace with new one, board fixed.

Hantarex MTC9000/A

No picture, Hole blown through LOPT. Had problems tracking down replacement – little tip given to me by Hantarex engineer – you can use the LOPT from an MTC9000 as long as you cut pin 2 off. (If you leave it connected, you will get a direct short to GND)

Gallag

Ran through self test OK, came up with chequer board screen and then reset most of the time. Occasionally would start game, but with credit noise continually playing and credits rapidly counting upwards. This is caused by CPU 4 (E5) not running properly. checked the eprom and ram (C5,D5 and E5) and ram was faulty….

Galaxian

No display – When move board, display flickers – go around board pushing each chip in turn, when press on 2E picture appears. Pin 16 rusted, only just in place. replace chip – picture back to normal. No star display. Board had been hacked to play an alternate game, pin 15 on chip 2B had…

Frogger (Sega)

Missing Chip. This was a converted moon cresta board. The IC at 1.2S (shoehorned in sideways between rows 1 and 2 by the sprite ram) was missing. This was not featured on any schematics I had, so I traced the connections to see what it could be. It basically takes the output from the sprite…

Do Run Run

Crashing game. Game woud start attract mode, but shortly after would crash and boot loop. Entering test mode (hold player 1 start button whilst switching on) and it would pass first time around, but fail at random addresses on subsequent runs. The /WAIT signal on the main Z80 is handled by the IC at E2…

Dark Seal

Glitched graphics. Screen changes as board is flexed. Moved around board pressing chips until pressing the custom surface mount chip at B6 changed the effect. Noticed that the corner most pins had come up from the board. After an unsuccessful effort to resolder them, I used some enameled 38 swg wire to solder from the…

Crazy Balloon

No Sound. Signal at output of SN76477 pin 13, follow through to input of sound amp, then from output until we reach electrolytic capacitor used to decouple  connection to speaker. Signal going in, nothing coming out – replace capacitor sound back to normal. Only drawing a few pixels of player balloon sprite. Following the schematics,…